当前位置:首页 > 问答

通达信画线显示价格

我来帮TA回答

求助 通达信画线指标显示价格

VV5:=CROSS(MA(C,10),MA(C,13));
现价:C,COLORYELLOW;
压力线:REF(C*1.0382,BARSLAST(VV5)),COLORCYAN,DOTLINE;
A:=IF(压力线<REF(压力线,1),压力线+1,0);
下台阶1:IF(COUNT(压力线<REF(压力线,1),30)>=2,4,0),COLORGREEN,NODRAW;
IF(COUNT(压力线<REF(压力线,1),30)>=2,C,DRAWNULL)COLORGREEN;
DRAWNUMBER(现价>0 AND CURRBARSCOUNT=1,C+1,现价)COLORCYAN;
以上是例,根据你的需要怎么修改借用,去编写吧。

通达信怎样实现在某个价位画水平线

DRAWLINE(X,H,REF(X,1),REF(H,1),1)COLORRED,DOTLINE;
STICKLINE(X,X,X,5,0),COLOR990099;
以上是两种不同的画线函数。
X为你设置的条件,根据你的需要进行修改吧。

求通达信主图指标,内容是 在指定的价格画线,比如6元画线,8元画线,10元画线等。

公式如下,但是下面的公式请在10元左右的股票中看好看些,股价高的和很低的请自行调整数字。
十元线:10;
八元线:8;
十二元线12:
注意,建该公式时,要建为主图公式!

如何在通达信分时图上自动画出满足某个条件的价格区间

画线可以但前提是有画线条件,还有分时图上显示当日最高价和最低价也没有什么意义啊。就是上下两条线呗。

请高手中的高手,编写一个通达信的自动画线公式,(包括长期趋势,中短期趋势线)

{N:=75;P:=5;P1:=10; 参数范围1---100}
A1:=REF(H,P)=HHV(H,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN,DOTLINE;
A2:=REF(L,P)=LLV(L,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED,DOTLINE;
AA1:=REF(C,P1)=HHV(C,2*P1+1);
BB1:=FILTER(AA1,P1);
CC1:=BACKSET(BB1,P1+1);
DD1:=FILTER(CC1,P1);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN LINETHICK2;
AA2:=REF(L,P1)=LLV(L,2*P1+1);
BB2:=FILTER(AA2,P1);
CC2:=BACKSET(BB2,P1+1);
DD2:=FILTER(CC2,P1);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED LINETHICK2;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
突破:C>短压 OR C> 长压,NODRAW;
DRAWICON(突破 AND REF(突破,1)=0,L*0.99,1);
手动调节参数以达到最佳效果,一定要提防假突破。

求通达信画线公式

M3:=EMA(CLOSE,3);
M8:EMA(CLOSE,8),COLOR008000;
M13:EMA(M8,13),COLOR0000FF;
M62:EMA(M8,55),COLORF0F000;
VAR1:=EMA(M13,62);
M81:EMA(M62,81),COLOR00FFFF;
M144:EMA(VAR1,144),LINETHICK2,COLOR0000FF;
M250:EMA(VAR1,250),POINTDOT,LINETHICK2,COLORF00FF0;
MA250:MA(CLOSE,250);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
散户1:EMA(CLOSE,5),COLORWHITE;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,18);
日:=150;昨前:=3;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED;
一0.809:REFDATE(H1,DATE),COLORYELLOW;
二0.618:REFDATE(H2,DATE),COLORMAGENTA;
三0.500:REFDATE(H3,DATE),COLORWHITE;
四0.382:REFDATE(H4,DATE),COLORGREEN;
五0.191:REFDATE(H5,DATE),COLORYELLOW;
低:REFDATE(低1,DATE),COLORRED; 源码给你了!加分 你还要等?真是没有意思,原来你是钓鱼。 呵呵做人不够厚道!“如图,类似的也可”??????
你可以不给分算我贡献百度的网站了! 你自己慢慢等吧。